Resolved
All systems functioning correctly
Monitoring
We have observed full recovery and will continue to monitor for 24H.
Monitoring
Customers experienced high latency in web server requests leading to failed network requests.
All scheduled operations were working as usual, no access issues.
We have deployed a fix and monitoring for full recovery.
Investigating
Reports of users being unable to access flows and workspaces. We are investigating the issue.